Trimble Connect Incident - Processing Service Delay - 3D Model Conversion - December 10 2025, 17:47 UTC

Incident

Trimble Connect Incident - Processing Service Delay - 3D Model Conversion - December 10 2025, 17:47 UTC

Status: closed
Start:
End:
Duration: 23 hours 34 minutes
Affected Components:
Processing Service (North America) Processing Service (Europe) Processing Service (Asia) Processing Service (Australia) 3D Model Conversion (New) 3D Model Conversion (New) 3D Model Conversion (New) 3D Model Conversion (New)
Update

We are seeing delays in the Trimble Connect Processing Service, which is responsible for uploaded 3D model conversions and are currently investigating the issue.

Update

A fix has been implemented for this issue but we continue to experience latency in some regions as the backlog of executions continues to clear.  We have increased resources to process the backlog as soon as possible.  We apologize for the inconvenience caused.  We will provide an update once the backlog has completely cleared.

Resolved

Backlog has been cleared and normal service has resumed.  We apologize for any inconvenience caused. Thanks for your patience.