Trimble Connect Incident - Interruptions in Public API - December 10 2025, 23:06 UTC

Incident

Trimble Connect Incident - Interruptions in Public API - December 10 2025, 23:06 UTC

Status: closed
Start:
End:
Duration: 1 hour 48 minutes
Affected Components:
Public APIs (North America) Public APIs (Europe) Public APIs (Asia) Public APIs (Australia) Overall Region Health Overall Region Health Overall Region Health Overall Region Health User Information User Information User License Information User Information Project Listing Project Listing User Information Project Listing Project Information Project Information Project Listing Project Information User Listing User Listing Project Information User Listing Folder Item Listing Folder Item Listing User Listing Folder Item Listing ToDo Listing ToDo Listing Folder Item Listing ToDo Listing 3D View Listing 3D View Listing ToDo Listing 3D View Listing 2D View Listing 2D View Listing 3D View Listing 2D View Listing System Search System Search 2D View Listing System Search Project Search Project Search System Search Project Search Organizer Service Organizer Service Project Search Organizer Service Property Set Service Property Set Service Organizer Service Topic Service Property Set Service Property Set Service Topic Service Topic Service Topic Service Topic Exchange Service Topic Exchange Service Model Feature Service Topic Exchange Service Topic Exchange Service Model Service Model Service Model Service Model Feature Service Model Feature Service Model Feature Service Model Service
Update

We are currently experiencing issues with Public APIs in multiple regions. We are investigating and will provide an update as soon as possible. We apologize for the inconvenience caused.

Update

We have located the issue on the Australia region and are working on a fix. We continue to investigate the impact on the other regions. We apologize for the inconvenience this continues to cause.

Update

A fix has been implemented for the issue within the Australia region; we are closely monitoring performance. We apologize for the inconvenience caused.

Resolved

The issue causing the disruptions has been resolved. Thanks for your patience.