Trimble Connect System Maintenance - Scheduled - April 05 2026, 12:00 UTC

Maintenance

Trimble Connect System Maintenance - Scheduled - April 05 2026, 12:00 UTC

Status: closed
Start:
End:
Duration: 1 hour
Affected Components:
Public APIs (North America) Public APIs (Europe) Public APIs (Asia) Public APIs (Australia)
Update

Trimble Connect’s Topics service will undergo scheduled maintenance across all regions on Sunday, 5 April, from 12:00 to 01:00 PM UTC. During this window, the BCF Topics service may be unavailable or may respond more slowly than usual. Service will return to normal once maintenance is complete.

We apologize for any inconvenience and appreciate your understanding.

Resolved

The scheduled maintenance has been completed.